Codehost: UNIX/Linux Printing with BrightQ Pro

Network Device Security and Management
Separator

Specifications

Supported Device List:
imageRUNNER 330/400 CLC 1100 - imagePASS-Z650
imageRUNNER 550/600/60 BJW 9000 - imagePASS-W20
imageRUNNER 2200/2800/3300/3300i imageRUNNER C3100
imageRUNNER 5000/5000i/6000 imageRUNNER C3100 - imagePASS-E1
imageRUNNER 5000/6000 - imagePASS-L1 imageRUNNER C5800/C6800
imageRUNNER 5020/5020i/6020/6020i imageRUNNER C5800/C6800 - imagePASS-D1
imageRUNNER 2220/2220i/3320/3320i imageRUNNER C5870/6870 - imagePASS-G1
imageRUNNER 2270/2870/3570/4570 imageRUNNER C4080/C4580/ C5180 -
imagePASS-H1
imageRUNNER 5070/5570/6570 imageRUNNER 5055 / 5065 / 5075 - imagePASS-S2
imageRUNNER 5570/6570 - imagePASS-M3 imageRUNNER 5050 - imagePASS-S2 V2.0
imageRUNNER 7200/8500/85/105 imageRUNNER 7086/7095/7105 V2 - imagePASS-S2
imageRUNNER 8500/85/105 - imagePASS-M1 and M2 Color imageRUNNER C2550
imageRUNNER 85+/8070/9070/105+ - imagePASS-M3 Color imageRUNNER 3080/3080i/3480/3480i
imageRUNNER 7086/7095/7105 Color imageRUNNER 3080/3080i/3480/3480i - imagePASS-J1 v1.1
imageRUNNER 7086/7095/7105 - imagePASS-S1 Color imageRUNNER C4080/C4080i/C4580/C4580i/C5185/C5185i V3 - imagePASS-H1V2.0
imageRUNNER 7086/7095/7105 V2 - imagePASS-S2 imageRUNNER ADVANCE C7065/C7055 - imagePASS-A1
Color imageRUNNER C2880 / C3380 - imagePASS-J1 imageRUNNER ADVANCE C9075/C9065
imageRUNNER 3025 / 3030 / 3035 / 3045 imageRUNNER ADVANCE C9075/C9065 - imagePASS-A1
Color imageRUNNER C5185 - imagePASS-H1 v1.2 imageRUNNER ADVANCE 6075/6065/6055
imageRUNNER 5055 / 5065 / 5075 V2 - imagePASS-S2 V2.0 imageRUNNER ADVANCE 6075/6065/6055 - imagePASS-U1
imageRUNNER Color 5058/5068 imageRUNNER ADVANCE 8105/8095/8085
imageRUNNER 7086/7095/7105 - imagePASS-S1 imageRUNNER ADVANCE 8105/8095/8085 - imagePASS-U1
Color imageRUNNER C2050/C2058 imageRUNNER 5050N
Color imageRUNNER C2620/C3200/C3220 imageRUNNER 5050N - imagePASS-S2 V2.0
Color imageRUNNER C2620/C3200/C3220 - imagePASS-C1 imageRUNNER ADVANCE C2020/C2030
Color imageRUNNER C2620/C3220 - imagePASS-C2 imageRUNNER 2545/2545i/2535/2535i/2530/2525
imageRUNNER 3245/3235/3230/3225 Color imageRUNNER C1030/1030iF
imageRUNNER 3235i/3245i imageRUNNER LBP3560
imagePRESS 1110S/1110P/1125/1135 imageRUNNER LBP3470
imagePRESS 1110S/1110P/1125/1135 - imagePRESS Server J100-J200 imageRUNNER ADVANCE 4051/4045/4035/4025
imageRUNNER ADVANCE C5051/C5045/C5035/C5030 imageRUNNER 1750/1750iF/1740/1740iF/1730/1730iF*
imageRUNNER ADVANCE C5051/C5045/C5035/C5030 - imagePASS-B1 Color imageRUNNER LBP5280
imageRUNNER ADVANCE C7065/C7055 imageRUNNER LBP3480

Note: Canon internal controller requires PS Printer Kit or supported external controllers as specified. All devices should be equipped with their appropriate Network Printer Kit. Also, please ensure the devices and controllers are equipped with the latest firmware.      

*
Currently does not auto-detect finishing options, but it is possible for users to manually select the correct configuration.

Supported Operating Systems:

Minimum Supported UNIX OS
Hardware
Sun Solaris 10 (SunOS)
UltraSPARC II or III
x86-Intel and Compatible
HP-UX 11i
PA-RISC (11.11) or Itanium (11.34)
FreeBSD 8.2
x86-Intel and Compatible
AIX 4.3
PowerPC

Note: IRIX and SCO are no longer supported as BrightQ Pro 2.5 and its minimum supported UNIX OS for Sun Solaris is version 9.

Linux Distribution
Minimum Supported Version
Red Hat Enterprise (RHEL) / CentOS
4
Fedora
7
SuSE / OpenSuSE
7.3
TurboLinux
10.0
Debian
3.0
Slackware
10
Ubuntu
9.10

The Linux version requires an Intel x86 or x86_64 (64-bit) processor.

Supported Linux Printing Systems

Linux Print Sytems
Minimum Supported Version
Recommended Version
Misc.
CUPS
1.1.15
1.1.20
CUPS is not supplied with BrightQ and must be installed as the default printing system prior to installing BrightQ
LPRng
3.79
3.8.26
LPRng is not supplied with BrightQ and must be installed as the default printing system prior to installing BrightQ
LPR, LPD (Berkeley Printing)
1.6.3.1
 

Supported Unix Printing Systems

Linux Print System
Minimum Supported Version
Recommended Version
Misc.
CUPS
1.1.15
1.1.20
CUPS is not supplied with BrightQ and must be installed as the default printing system prior to installing BrightQ
AIX
4.3
4.3
Default print system on AIX System V is also available starting with AIX 5
LPRng
3.79
3.8.26
LPRng is not supplied with BrightQ and must be installed as the default printing system prior to installing BrightQ
LPR, LPD (Berkeley Printing)
1.6.3.1